Uploaded image for project: 'Swift'
  1. Swift
  2. SR-13553

SwiftSyntax doesn't work in Xcode 12 with Swift 5.3.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Medium
    • Resolution: Done
    • Component/s: SwiftSyntax
    • Labels:
      None

      Description

      Xcode 12 just went GM today and iOS 14 is scheduled to be released tomorrow but we don't have a Swift 5.3 version available in SwiftSyntax to be able to update the libraries that use it in Xcode 12.

       

      I've tried using the last available release to date https://github.com/apple/swift-syntax/releases/tag/swift-DEVELOPMENT-SNAPSHOT-2020-09-11-a and the last Xcode available (Version 12.0 (12A7208)) and I'm getting 

       

      > stderr: Error: The loaded '_InternalSwiftSyntaxParser' library is from a toolchain that is not compatible with this version of SwiftSyntax

      when running SwiftSyntax.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            fdiaz Francisco Diaz
            Votes:
            2 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: