Uploaded image for project: 'Swift'
  1. Swift
  2. SR-3405

the package has an unsupported layout

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Medium
    • Resolution: Won't Do
    • Component/s: Package Manager
    • Labels:
      None
    • Environment:

      3.0.1 Xcode 8.1

      Description

      In 0019 ,the below layout is listed as supported but it doesn't work.

      Package
      └── Sources
          ├── Foo.swift
          └── Tests
              └── Test.swift
      

      https://github.com/apple/swift-evolution/blob/master/proposals/0019-package-manager-testing.md

      error: the package has an unsupported layout, unexpected source file(s) found: /random/Tests/AccumulateTest.swift

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              masters3d Chéyo Jiménez
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved: