Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[SR-2415] Could #keyPath be smarter about setter/getter names? #45020

Open
mattneub opened this issue Aug 19, 2016 · 0 comments
Open

[SR-2415] Could #keyPath be smarter about setter/getter names? #45020

mattneub opened this issue Aug 19, 2016 · 0 comments
Labels
bug A deviation from expected or documented behavior. Also: expected but undesirable behavior. compiler The Swift compiler in itself

Comments

@mattneub
Copy link

Previous ID SR-2415
Radar None
Original Reporter @mattneub
Type Bug
Environment

Xcode Version 8.0 beta 6 (8S201h)

Additional Detail from JIRA
Votes 7
Component/s Compiler
Labels Bug
Assignee None
Priority Medium

md5: 96414707255510267f6831d0ef5651f8

Issue Description:

This doesn't work:

        av.addObserver(
            self, forKeyPath: #keyPath(AVPlayerViewController.isReadyForDisplay), options: .new, context: nil)

The problem is that we are trying to KVO observe changes in an AVPlayerViewController's "isReadyForDisplay" property. But no change notifications are triggered. Why? The reason is that "isReadyForDisplay", although it is now officially the Swift name of this property, is actually only the getter name; the setter name is "readyForDisplay", and that's what we are trying to observe, i.e. setting.

So I'm suggesting that the new renamification which uses the getter with "is" as the name of the property in Swift is going to mislead users and their KVO attempts will fail. But maybe #keyPath could be smarter about this and translate behind the scenes into the real name of the property?

@swift-ci swift-ci transferred this issue from apple/swift-issues Apr 25, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
bug A deviation from expected or documented behavior. Also: expected but undesirable behavior. compiler The Swift compiler in itself
Projects
None yet
Development

No branches or pull requests

1 participant